User Tools

Site Tools


Image Editing

Before you can work with images, they need to be imported into the StudioLine Image Archive. The image toolbox can be accessed via the Menu Bar item “Image”, or via the Tool Bar button: “Image Tools”.

In StudioLine, you edit your pictures by applying image tools to them. Each image tool performs a specific effect to a picture. For instance, there are tools to rotate and crop, adjust color tones, correct red-eye problems, as well as various special effect filters.

For each image, StudioLine will only save the tool settings you chose and apply them before an image is displayed or otherwise used. The master copy in the Image Archive remains unchanged. This way, you can experiment with image tools change settings or reverse any actions – even months later.

Applying an Image Tool

Image Tools are grouped by the following three functions:

  • Preprocessing: These tools perform initial corrections such rotate, crop, and red-eye correction, all of which should occur before optimizing colors, exposure, and other aspects.
  • Correction: These tools are used to optimize your images, for example, by correcting blurring, improving exposure, and addressing color shifts.
  • Effects: The fun filters: let your creativity run wild!

To apply an image tool to a picture in the Image Archive, select one or more with a mouse click, then choose an image tool which opens automatically in the Edit Bar. As you select more image tools, they too will be added to the Edit Bar. If room for all image tools becomes scarce, click on the minimize button in an Image Tool Title bar to minimize it. You can also undock an image tool by clicking the undocking button. Click the same button to re-dock the tool to the image tools pane.

Each Image Tool has its own panel with the settings for the selected tool. Use the various controls to achieve the desired results. StudioLine will instantly update the picture to show the effect. There is no need to confirm your actions with an “OK” button. All tools and settings can easily be changed or reversed at any time.

A tool can be applied to multiple images at once by selecting these images before accessing any tools or changing settings.

Image Preprocessing Tools

One of the key features of StudioLine is the ability to apply a complete set of image optimizations to an entire series of similar pictures. For proper image alignments, to crop unwanted borders, or to correct unappealing red pupil discolorations in people or animals (Red Eye Removal), use the appropriate tool from the “Preprocessing” section of the “Image Tools” panel.

Since pre-processing tools are specific to each picture and would not be copied to other images, they are omitted from the “Active Image Tools List”.

You have quick access to preprocessing tools like “Rotate”, “Crop” and “Red Eye Removal” from the Bottom Bar.

Active Image Tools List

StudioLine collects all tools, filters, and their settings in a stack (the “Active Image Tools” list), which is stored along with the unchanged original in the Image Archive. To view the active image tools list, select an image and right click on the Active Tools Object Icon below it. This will open up the window displaying the applied tools. Alternatively you could follow this Menu Bar path: “Image” → “Active Image Tools.” You can also right-click on an image and choose “Active Image Tools” from its context menu.

Changing the Processing Order

You can control the order in which tools are applied against an image by moving them around within the Active Image Tools list. StudioLine will apply the tools top to bottom.

To illustrate the effect of different processing orders, select an image, apply the “Black & White” tool, then the “Colorize” tool to achieve a sepia effect. This will give the picture an aged appearance. If you reverse the sequence of the filters, then the “Black & White” filter cancels out the “Colorize” tool.

Discarding Tool Settings

To discard the effect of an image tool, simply drag the tool icon from the “Active Image Tools” list of a particular image into the Recycle Bin in the upper right corner of the StudioLine window. You can also right-click on any tool icon in the list and choose “Delete” from the context menu. Alternatively, if the tool’s settings panel is currently open, you can select the particular image and drag the “Copy” button from the top left corner of the tool’s settings panel to the Recycle Bin.

Copying Settings

There are a number of ways to copy tool settings from one image to another.

  1. Dragging the “Copy” Button to a Single Image
    Click on the image containing the correct image tools settings. Open the image tool you wish to copy. Drag the “Copy” button of the image tool’s settings panel to any other image that should inherit the identical settings.
  2. Clicking the Copy Button
    Click on the image containing the correct image tools settings. Open the image tool you wish to copy. Hold down the “Ctrl” key to select additional images (be certain that the original image remains selected). Click the “Copy” button of that image tool’s settings panel to apply the same settings to all selected images.
  3. Using the Active Image Tools List
    To copy the settings of a single image tool, drag that particular tool from the Active Image Tools list to any target images. (Right-clicking on the Active Image Tools Status Icon below the image will open the Active Image Tools window.) To copy all image tools, drag “Copy” button of the Active Image Tools list onto any target images (or use the “Ctrl” key to select additional images and then click the “Copy” button).

The “Lock” button (see below) assists in copying tools and settings to images in other folders.

Normally, the Tool panel will display the settings in effect for the currently selected image. If multiple pictures are selected, the panel will display the settings for the image that was selected first. Clicking the “Lock” button will turn the button red, indicating that the settings are locked. You are now free to browse through folders and select different images – the settings will remain “frozen” on the originally selected picture. When you have located and selected the target image(s), click the “Copy” button in the settings panel to transfer the tool settings to them.


The histogram displays the distribution of pixels based on brightness and frequency in your image. The x-axis (horizontal) represents brightness ranging from black (0) to white (255). The y-axis (vertical) represents the frequency of pixels for each particular brightness.

Ideally, an image should display an even balance of dark, mid-range, and bright pixels. Images with an excessive number of bright pixels will appear washed out. An image too high in mid-range pixels will appear pale. Too many dark area pixels will result in a lack of detail. The StudioLine histogram helps with assessing the effect of image tools to attain a well balanced picture.

The histogram can be switched to different views to match various image tools. “Red/Green/Blue” is the default view, showing the distribution of brightness combined for all color channels. You can also select one or multiple individual color channels, or view the distribution of saturation or color. In addition, you can choose logarithmic or linear view and overlay the chart with a grid.

To illustrate the use of the histogram, let’s take a look at the “Auto Tone Levels” tool. Select a pale or washed-out looking image lacking contrast. Open the “Auto Tone Levels” tool from the Image Toolbox. In the histogram at the top of the Image Tools Bar the setting should already be the default “Red/Green/Blue” – if not, click on the fourth circular button from the left, the grey one, next to the individual color channel buttons and the black/white “Hue” button.

The image example above nicely illustrates the lack of pixels on the right in the graph. After clicking on “Auto-Contrast” in the “Auto Tone Levels” panel, the histogram shows how the graph is now spread across the entire brightness range.

The balanced brightness results in a much more vibrant image. You can further move the sliders in the “Auto Tone Levels” panel and instantly observe the result in the histogram and on the image itself.

Editing with Third-Party Applications

You can open images in your favorite image editing tool directly from the Image Archive. Right-click on an image, choose “Original” from the context menu, and select the menu item “Open With”. You will see a list of applications that Windows has associated with the file type of the original image. There will also be an option “Choose Program …” to manually pick a specific program. Use the option “Edit Program Shortcuts” to define shortcuts to your own program choices.

In the panel “Create New Program Shortcut” enter a shortcut name. Then use the “Browse” button to locate the appropriate program file. Accept your choices with the “OK” buttons and you will see your new program shortcut appear in the context menu. You can manage any existing program shortcuts in the panel “Edit Program Shortcuts”. Click the “New” button to create another program shortcut. Once selected, your application will launch and you can edit the picture. When done simply save the file and close it.

When launching third-party applications from StudioLine, you should be mindful of certain facts:

  • Any changes made with third-party applications cannot be reversed by StudioLine. If that is a concern, make a copy of the picture before making any changes. Right-click the image and choose “Create Duplicate” from the context menu.
  • Many programs offer a “Recent Files” list in the application’s “File” menu. Do not use the “Recent Files” list or any other third-party technique to open StudioLine-managed pictures, as StudioLine would not register any changes made. Instead, always open these pictures by launching the application directly from the Image Archive.
  • Do not close StudioLine while you are editing a StudioLine-resident image with a third-party application. If you closed StudioLine, then do not start it again until after you have completed your work and exited the third-party application. If your changes did not carry over into StudioLine after restarting, right-click the image, choose “Original” from the context menu and select the “Refresh” function.
  • Any changes you have made to an image with StudioLine will not show up in the third-party application. Since StudioLine does not actually change the source image, the effects of any filters or tools applied by StudioLine will not be available to the third-party application. Therefore, you should limit the use of third-party applications to those effects that cannot be accomplished with StudioLine tools. Only StudioLine tool changes can be edited and reversed at any time.
  • Once you have completed your work in the third-party application, choose the normal “Save” option in the application’s “File” menu, or the closest equivalent. “Save” will simply replace the image on the hard disk. Do not use “Save As” or “Save as Copy” or similar advanced functions, because StudioLine would not know where to find the updated picture.

Making Changes to Your Images Permanent

When exporting images to standard graphics files, you have the choice of including the effects of all tools and filters performed within StudioLine (see the section “Exporting” elsewhere in this manual). Sometimes, it may be desirable to make changes to an image permanent even though it will stay in the Image Archive. Do this by right-clicking on an image, choosing the submenu “Image with Image Tools Applied” and select one of the available functions:

  • Open Copy With
    This function is equivalent to the function “Original”, “Open With”, discussed previously in the section “Editing with Third-Party Applications”. However, this time StudioLine will first create a copy of the selected image and its descriptors, as well as permanently incorporate the effects of all filters and tools, including any image preprocessing. The copy will have an empty “Active Image Tools” list because all editing has been permanently fused into the copy. All descriptors will, however, be carried over to the copy. This copy will then be opened in the third-party application.
  • Create Copy
    Here StudioLine does the same thing as in the previous function “Open Copy With”, but does not go on to open the copy in a third-party application. As above, the copy will have an empty “Active Image Tools” list because all tools have been processed and directly rendered into the copy. All the descriptors will nevertheless be retained.
web/image_editing.txt · Last modified: 2013/11/11 12:43 by henning_stummer